I decided to re-pave my main box this weekend and as Asus aren’t supporting the A8V Deluxe motherboard in Vista, I thought I'd switch to working 64bit anyway and installed Windows XP x64 instead. Which, having had the benefit of being out for a good couple of years in now reasonably supported - well, almost. The advantage XP64 has is that it does support much newer motherboards by itself and indeed half the drivers I would have installed from the CD that came with the mobo were installed by default anyway. And so what if there is no x64 driver for AMD Cool n Quiet? I’ll live. nVidia is also very good with drivers as well. Forceware v93.71 works just fab and groovy.

Of course, it hasn’t been all wine and roses. The mobo’s wireless LAN card and Sound Blaster X-Fi also needed drivers and ASUS don't even acknowledge the LAN card’s existence on their site. Fortunately, the forums at start64.com and planetamd64.com helped out and pointed me at the RalinkTech site - the guys who made the card before ASUS actually branded it. A godsend; they even have Vista x86\x64 drivers as well so why ASUS couldn’t be bothered to advertise this fact is beyond me.

Last but not least, Creative. A proud owner of an x-Fi ExtremeMusic card, it’s a shame that while the x64 driver is on their site, it may take a couple of goes to find it. Go to the main download page and you’re asked to select your product. Click X-Fi, then SoundBlaster and ExtremeMusic doesn’t appear. Oh no, you have to click SoundBlaster first, and then X-Fi and there she is. Exactly how this particular piece of nonsensical user interface was allowed into the wild I don’t know but it definitely is a stumper. Trying to install the wrong driver doesn’t help either. You just get a message saying it’s the wrong driver, rather than what the driver being installed is actually for. Wake up, Creative. We are dumb and crave sensible UI and helpful error messages.